tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Geoff Soutter" <ge...@whitewolf.com.au>
Subject Re: JVM core dump with JDK1.3 win32 due bad File Descriptor
Date Fri, 22 Sep 2000 00:20:18 GMT
As Craig recently reminded me:

If the JVM crashes and it's using zero native code, then the only possible
cause is a JVM Bug.

It may be related to this bug I found on the the BugParade which looked
kinda similar:

http://developer.java.sun.com/developer/bugParade/bugs/4369396.html

looks like the 1.3 Win32 JVM is more of a beta release than an FCS release
(I think they released it to co-incide with JavaOne didn't they?).
-( Hopefully they'll refresh it soon...

cheers

Geoff

----- Original Message -----
From: "Sebastien Sahuc" <ssahuc@imediation.com>
To: <tomcat-dev@jakarta.apache.org>
Sent: Friday, September 22, 2000 7:45 AM
Subject: JVM core dump with JDK1.3 win32 due bad File Descriptor


Hello,

Here is a post I've sent to the Jboss list:

  Hello,

  I don't know if it was done yet, but I finally succeeded in integrating
  Catalina in jboss.

  It wasn't a piece of cake, since it generates core dumps on my win
JDK1.3
  JVM.
  I was getting EXCEPTION_ACCESS_VIOLATION from all the place, and when I
  forced to NON JIT, the error was a 'little' more explicit : '
  java.util.MissingResourceException can't find bundle for base name
  org.apache.catalina.valves.LocalStrings'
  whereas the resource was in the catalina.jar !!!!

  So I traced down the ResourceBundle which took me way too long... in
  java.util.ResourceBundle I had to trace an exception that was caucht
but
  simply ignored :-( (line 944)
  Finally the original exception is :
  java.io.IOException: Bad file descriptor

  Does anyone know what this mean ? Is there some limit in these file
  decriptors ?

   Is it a JVM bug (because with JDK1.2.2 win it does work) ?

  So to make everything working, I had to extract from the catalina.jar
the
  necessary LocalStrings.properties (there is 10 of them) into a classes
  directory, and after reshaping the classpath, everything worked fine.
Any
  idea on what's happening ?

  So beside this issue, I'm willing to share with the other my
  'CatalinaMBean', and the guideline (way similar to Tomcat3.x). Thus I'm
  expecting directive from the board :-)

  All the best,

  Sebastien


Has anybody an idea of what is going on ?

All the best,

Sebastien



---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org




Mime
View raw message