tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Paulo de Barcellos" <>
Subject Re: Tomcat and Apache together
Date Tue, 08 Aug 2000 20:17:47 GMT
That´s the way I did (Mandrake 7.0 - Apache 1.3.9 - Tomcat 3.1):

0) Compile (the binary version didn´t work with my Apache version)
1) Put in /usr/lib/apache
2) Make a symbolic link: ln -s /usr/lib/apache /etc/httpd/libexec
3) Include /usr/local/jakarta-tomcat/conf/tomcat-apache.conf (I don´t include tomcat.conf)
at the end of /etc/httpd/conf/httpd.conf
4) Start Tomcat (the file tomcat-apache.conf is automatically generated now)
5) Start Apache

I think it should help...

  ----- Original Message ----- 
  From: Webmaster 
  Sent: Tuesday, August 08, 2000 9:48 AM
  Subject: Re: Tomcat and Apache together

  Yes, I've tried every combination known to man, I just can't get Apache to start when tomcat's
conf file is included at the end.  I think it might be the module but I'm doing
that all right too because I know the directory structure is right and know I'm putting it
in the right place because that's where my php and perl module is.  Argh!  If anyone can help
please give me a hand, I really need this up and running!  Thanks in advance for any advice!
    ----- Original Message ----- 
    From: Voronoff, George 
    To: '' 
    Sent: Monday, August 07, 2000 7:41 PM
    Subject: RE: Tomcat and Apache together

    Don't know if this will even make a difference, or if you have done it this way anyway,
    but did you start tomcat before starting apache?
      -----Original Message-----
      From: Webmaster []
      Sent: Monday, August 07, 2000 4:04 PM
      Subject: Tomcat and Apache together

      I am having a big problem getting Tomcat and Apache to run together.  I can get both
to run alone when I comment out the include statement at the end of the httpd.conf file which
I have as

      include /usr/local/jakarta-tomcat/conf/tomcat.conf

      When that statement is commented out I can get Apache to run and Tomcat to run by itself.
 When I shut down Apache, remove the comment and try to start apache using 
      apachectl start

      I get an error saying that Apache cannot be started.  I  thought at first I wasn't putting
the file in the right place but when i started playing with the location in the
tomcat.conf file I was actually getting an error saying that it couldn't find the
file, so when i changed it back, all I get is that Apache can not start.  I know tomcat.conf
is getting included but there's something in that file that's wrong.  I didn't edit anything
else in the file except for the LoadModule for the  I even built the
file myself instead of using the binary on apache's site...which I've tried as well and get
the same results.  Am I doing something wrong?  Both work wonderfully separately but I would
like to be able to get them to work together for obvious reasons.  Any help is greatly appreciated.

      Robert L. Brueckmann
      7400 York Road, Suite 405
      Towson, MD 21204
      ph: 410-337-5444
      fax: 410-337-5585

View raw message