tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Edward Wolpert <>
Subject Re: Tomcat, Catalina, and Java2
Date Mon, 10 Jul 2000 23:10:23 GMT
"Craig R. McClanahan" wrote:
> Edward Wolpert wrote:
> > we might want to wait for Tomcat 4.x to require Java2.
> > (Well, I'm sure the FreeBSD folks will have the JDK1.2.2 done by then,
> > but I'm not sure about the 1.3 port.)
> As I indicated in the original post, Catalina is going to be proposed for
> Tomcat 4.x, not 3.x.  If the final version of the Servlet 2.3 spec requires
> J2SE, there will be no reason not to use such features inside Catalina -- it
> just won't run on platforms without a compatible Java environment until one
> becomes available.

The only issue I see for Tomcat 4.x is if it needs Java 1.2.x versus
Java 1.3.x.
I agree that Tomcat 4.x should be able to require Java2, but which
version of the
run time is necessary?   (Some security API's require Java 1.3.x, like


Edward Wolpert

View raw message