tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Aleksey Tsalolikhin <atsal...@earthlink.net>
Subject Re: build "mod_jserv.so" error
Date Sat, 08 Jul 2000 01:14:41 GMT
Dear Tomcat developers,

  I downloaded the 3.2-beta-1 source tree and built tomcat.
It starts up ok in standalone mode, the jsp examples work fine.
Now I'm trying to get my Apache 1.3.12/mod_ssl talking to Tomcat,
but am having trouble building mod_jserv.so.  Any assistance
would be MUCH appreciated.

When I run "apxs -c -o mod_jserv.so *.c" in
jakarta-tomcat-3.2b1/jakarta-tomcat/src/native/apache/jserv,
it dies with

gcc -DOSF1 -DMOD_SSL=206105 -DUSE_HSREGEX -DEAPI -DEAPI_MM -DUSE_EXPAT -I../lib/ex
pat-lite -DNO_DL_NEEDED  -I/usr/local/apache/include  -c mod_jserv.c
  -o mod_jserv.so mod_jserv.o jserv_wrapper_win.o jserv_wrapper_unix.o jserv_wrapp
er.o jserv_watchdog.o jserv_utils.o jserv_status.o jserv_protocols.o jserv_mmap.o
jserv_image.o jserv_balance.o jserv_ajpv12.o jserv_ajpv11.o autochange.o
apxs:Break: Command failed with rc=16711680

I tried then running

ld -G mod_jserv.so mod_jserv.o jserv_wrapper_win.o jserv_wrapper_unix.o jserv_wrap
per.o jserv_watchdog.o jserv_utils.o jserv_status.o jserv_protocols.o jserv_mmap.o
 jserv_image.o jserv_balance.o jserv_ajpv12.o jserv_ajpv11.o autochange.o

per http://www.metronet.com/~wjm/tomcat/FromFeb11/msg02567.html,
which produced an a.out.  I renamed it mod_jserv.so, but Apache
can't load it.

# cat ~atsaloli/jakarta-tomcat-3.2b1/jakarta-tomcat/src/native/apache/jserv
/a.out > /usr/local/apache/libexec/mod_jserv.so
# /usr/local/apache/bin/apachectl start
Syntax error on line 1 of /usr/users/atsaloli/jakarta-tomcat-3.2b1/build/tomcat/co
nf/tomcat-apache.conf:
Cannot load /usr/local/apache/libexec/mod_jserv.so into server: dlopen: cannot loa
d /usr/local/apache/libexec/mod_jserv.so
/usr/local/apache/bin/apachectl start: httpd could not be started
#

  What am I missing, please?

# /usr/local/apache/bin/httpd -V
Server version: Apache/1.3.12 (Unix)
Server built:   Jul  6 2000 22:37:08
Server's Module Magic Number: 19990320:7
Server compiled with....
 -D EAPI
 -D EAPI_MM
 -D EAPI_MM_CORE_PATH="logs/httpd.mm"
 -D HAVE_MMAP
 -D USE_MMAP_SCOREBOARD
 -D USE_MMAP_FILES
 -D USE_FLOCK_SERIALIZED_ACCEPT
 -D SINGLE_LISTEN_UNSERIALIZED_ACCEPT
 -D SHARED_CORE
 -D HTTPD_ROOT="/usr/local/apache"
 -D SUEXEC_BIN="/usr/local/apache/bin/suexec"
 -D SHARED_CORE_DIR="/usr/local/apache/libexec"
 -D DEFAULT_PIDLOG="logs/httpd.pid"
 -D DEFAULT_SCOREBOARD="logs/httpd.scoreboard"
 -D DEFAULT_LOCKFILE="logs/httpd.lock"
 -D DEFAULT_XFERLOG="logs/access_log"
 -D DEFAULT_ERRORLOG="logs/error_log"
 -D TYPES_CONFIG_FILE="conf/mime.types"
 -D SERVER_CONFIG_FILE="conf/httpd.conf"
 -D ACCESS_CONFIG_FILE="conf/access.conf"
 -D RESOURCE_CONFIG_FILE="conf/srm.conf"
# uname -s -r
OSF1 V5.0
# 

  My Apache src/Makefile.config contains the following:

CFLAGS_SHLIB= -DSHARED_MODULE
LD_SHLIB=ld
LDFLAGS_SHLIB=-shared -expect_unresolved "*" -s
LDFLAGS_SHLIB_EXPORT=
LDFLAGS_MOD_SHLIB=-shared -expect_unresolved "*" -s

Thanks in advance for ANY lead,
Aleksey Tsalolikhin

-- 
Aleksey Tsalolikhin
System Administrator
InsureSuite, Inc.

Mime
View raw message