tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Geoff Soutter" <ge...@whitewolf.com.au>
Subject Re: clean build of tomcat from CVS fails
Date Wed, 26 Jul 2000 08:00:23 GMT
Hi,

> I am using Windows98 + JDK1.3, tomcat compiles well. Except with the
missing dtd
> whenever you run. I have already mailed the patch for copying the dtd in
> build.xml. But seems not reflected in the current CVS.
>
> Maybe the you clean is not a clean one? (without build clean) Or you have
> classpath already set to something old tomcat library?

I have a clean classpath, with only JAXP in it, and I am building in a newly
created directory structure.

Do you have the .java file that is apparently missing as mentioned below -
org.apache.jasper.servlet.JasperLoader ??

cheers

geoff

>
> Arion
>
> Geoff Soutter wrote:
>
> > Hi there,
> >
> > I'm attempting a clean build of the tomcat source from CVS on WinNT
using
> > JDK1.2.2, according to the README in the root of jakarta-tomcat
> >
> > I compiled ant fine, but tomcat fails with the following messages:
> >
> > tomcat:
> >     [javac] Compiling 3 source files to
> > D:\apps\jakarta\latest\build\tomcat\classes
> >     [javac]
> >
D:\apps\jakarta\latest\jakarta-tomcat\src\share\org\apache\jasper\CommandLin
> > eContext.java:78: Class org.apache.jasper.servlet.JasperLoader not
> > found in import.
> >     [javac] import org.apache.jasper.servlet.JasperLoader;
> >     [javac]        ^
> >     [javac]
> >
D:\apps\jakarta\latest\jakarta-tomcat\src\share\org\apache\jasper\JspC.java:
> > 74: Class org.apache.jasper.servlet.JasperLoader not found in impor
> > t.
> >     [javac] import org.apache.jasper.servlet.JasperLoader;
> >     [javac]        ^
> >     [javac]
> >
D:\apps\jakarta\latest\jakarta-tomcat\src\share\org\apache\jasper\JspEngineC
> > ontext.java:76: Class org.apache.jasper.servlet.JasperLoader not fo
> > und in import.
> >     [javac] import org.apache.jasper.servlet.JasperLoader;
> >     [javac]        ^
> >     [javac] 3 errors
> >
> > BUILD FAILED
> >
> > any ideas whats happening?
> >
> > cheers
> >
> > geoff



Mime
View raw message