tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <cos...@costin.dnt.ro>
Subject Re: SSL Issues
Date Wed, 14 Jun 2000 22:23:08 GMT
I just started - it's not ready yet. 

I'll add a hook in ServerFactory to allow it to set Request parameters (
certs, etc ), but I need some time ( or patches :-). 


Costin



On Wed, 14 Jun 2000, Arieh Markel wrote:

> I have been able to successfully connect to the SSL socket factory using
> an https request, I begun debugging the servlets that I expose through the 
> website.
> 
> My initial servlet is a 'login' servlet.
> 
> After printing the HttpServletRequest headers and parameters, I
> am wondering whether the 'handler' needs to be sensitive to the request.
> 
> This, since the servlet sees no difference between the request for
> http and https:
> 
> 	request.isSecure == false
> 	request.protocol == HTTP/1.0
> 	
> (the protocol will probably remain the same, since the SSL capability is
> on the transport and not on the protocol. However, I was expecting the
> 'isSecure()' call to return false in one case (http), true in the other
> (https)).
> 
> Has anybody ran into something similar ?
> 
> Arieh
> --
>  Arieh Markel		                Sun Microsystems Inc.
>  Network Storage                        500 Eldorado Blvd. MS UBRM11-194
>  e-mail: arieh.markel@sun.COM           Broomfield, CO 80021
>  Let's go Panthers !!!!                 Phone: (303) 272-8547 x78547
>  (e-mail me with subject SEND PUBLIC KEY to get public key)
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org
> 


Mime
View raw message