tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vasile GABURICI <gabur...@ss.pub.ro>
Subject Solaris question
Date Sat, 03 Jun 2000 04:03:24 GMT
I'm trying to make the AOLserver module work on Solaris 7, but I get the
following error when I try to dlopen() the JVM (1.2.2_005 reference):

<quote>

You must install a Solaris patch to run the native threads version of the
Java runtime.  The green threads version will work without this patch. 
Please check the native threads release notes for more information. 

If you are embedding the VM in a native application, please make sure that
the native application is linked with libthread.so (-lthread). 

Exiting. 

</quote>

Now, it doesn't seem like I miss a patch because java -native works.  So,
it seems like the second issue is the problem. My module (and AOLserver)
is built with -lpthread. Is there an incompatibility between -lthread that
the JVM seems to use and -lpthread that AOLserver is using? 



Mime
View raw message