tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lian.Colb...@bridge.bellsouth.com
Subject Error build sample on NT4 SP5 - latest release build of tomcat - JDK 1.2.2
Date Wed, 21 Jun 2000 18:48:57 GMT
I posted this message some time back, here's something I've done to make it
work. I thought other people might benefit from this:

1. The first build.XML property tag:
<property name="app.name"       value="myapp"
Does not have an end tag. It should be:
<property name="app.name"       value="myapp"/>

This gets rid of the Java exception.
(Tom from tech@thomassmith.com has helped me on this.)

2. After step one, you'll run into "BUILD FATAL ERROR: srcdir does not exist!"
error, to solve this, you can either create a empty directory: 
      %TOMCAT_HOME%\doc\appdev\sample\lib

 or alernatively, you can delete the reference line from the build.xml:
=======================
 <target name="prepare" init="init">
    <mkdir dir="${deploy.home}"/>
    <copydir src="web" dest="${deploy.home}"/>
    <mkdir dir="${deploy.home}/WEB-INF"/>
    <copyfile src="etc/web.xml" dest="${deploy.home}/WEB-INF/web.xml"/>
    <mkdir dir="${deploy.home}/WEB-INF/classes"/>
    <mkdir dir="${deploy.home}/WEB-INF/lib"/>

    <copydir src="lib" dest="${deploy.home}/lib"/> !!! delete this line!!!
                  ^^^^^^^^^Delete the above line^^^^^^^^^^^^^^^         

    <mkdir dir="${javadoc.home}"/>
  </target>
===========================

3. After that I got NoClassDefined exception for: sun.tools.javac.Main, I added
the following line in the build.bat:

==========================================
:restofclasspath
      ^^^^^^^^^Newly added started
CLASSPATH=%CLASSPATH%;%JAVA_HOME%\lib\tools.jar   
      ^^^^^^^^^Newly added end

set CLASSPATH=%CLASSPATH%;%TOMCAT_HOME%\lib\ant.jar
==========================================


That's it. Good luck!

-Lian Colburn
(205)977-1646

=->I'm new here, I downloaded the latest Tomcat release build, and I'm having
=->trouble building the sample program in the the doc directory, here's the
error
=->message I got:
=->
=->" Buildfile: build.xml
=->BUILD CONFIG ERROR: Can't open config file: build.xml due to:
=->org.xml.sax.SAXParseException: Attribute names must not start with "<"
=->characters. "
=->
=->Here's my environment setting:
=->Windows NT 4.0 Release 5
=->Sun JDK 1.2.2
=->
=->I had no trouble starting the Tomcat. I guess I must have just missed
something
=->important/obvious?
=->
=->( I do have Apache server running, it should not matter, but I just want to
=->mention it)
=->
=->Thanks.
=->
=->-Lian Colburn
=->  
=->
=->
=->
=->---------------------------------------------------------------------
=->To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
=->For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org
=->
=->
 



Mime
View raw message