tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Glenn Nielsen <gl...@voyager.apg.more.net>
Subject Re: Wrongful JDK 1.2 requirements
Date Tue, 13 Jun 2000 00:31:20 GMT
Between JavaOne and other things I haven't had time to look at
Costin's latest changes such as creating the interceptor.

There is 1.2 specific code in Jasper that was required to support
use of a SecurityManager.  In JspLoader support for using defineClass()
with a ProtectionDomain and a number of AccessController doPriviledged()
calls in JspLoader and some of the compiler classes.

Has a consensus been reached that both Jasper and Tomcat should compile
under both 1.1 and 1.2?  

And that where 1.2 specific code is needed seperate class files will be 
maintained with build.xml modified to detect which jdk to compile for?

I can make the above changes if thats what the consensus is.

Regards,

Glenn

costin@costin.dnt.ro wrote:
> 
> > Sounds reasonable.  I look forward to building under 1.1 again.  :-)
> 
> Later this week ( if nobody else does it), I have a bit too much to do.
> 
> Costin
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org

-- 
----------------------------------------------------------------------
Glenn Nielsen             glenn@more.net | /* Spelin donut madder    |
MOREnet System Programming               |  * if iz ina coment.      |
Missouri Research and Education Network  |  */                       |
----------------------------------------------------------------------

Mime
View raw message