tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jason Hunter <jhun...@acm.org>
Subject Re: Wrongful JDK 1.2 requirements
Date Mon, 12 Jun 2000 20:56:08 GMT
Sounds reasonable.  I look forward to building under 1.1 again.  :-)

-jh-

costin@costin.dnt.ro wrote:
> 
> > > The only hard problem is AdaptiveClassLoader - where we have to use
> > > defineClass() with ProtectionDomain if policy is used. I can fix that if
> > > you need to compile with 1.1.
> >
> > What fix would you make?  The interceptor issues can be fixed with
> > conditional compiles.  Can this?
> 
> Create an AdaptiveClassLoader12 that is dependent on 1.2 and uses the
> right method.
> Change LoaderInterceptor to set the 12 version if 1.2 is detected ( or
> even better, create LoaderInterceptor12 that will be used in 1.2 config).
> 
> Costin
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org

Mime
View raw message