tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "B.J. Weschke" <b...@inet-images.com>
Subject RE: Tomcat+Apache not working
Date Wed, 05 Apr 2000 10:04:09 GMT

 Ajpv12 changed sometime in the last couple of weeks. What's up on that site
is the older version of mod_jserv.so which will result in the apache process
hanging when you try to hit Tomcat through it. You need to compile the
module from the present source tree. 

-----Original Message-----
From: Jesper Jørgensen [mailto:jesper@caput.com]
Sent: Wednesday, April 05, 2000 5:51 AM
To: tomcat-dev@jakarta.apache.org
Subject: Tomcat+Apache not working


The current tomcat code does not seem to work with the Apache Jserv
connector.

Setup:

Redhat linux 6.1
Apache 1.3.9 with mod_jserv.so (downloaded from
http://jakarta.apache.org/builds/tomcat/release/v3.1_beta_1/bin/linux/i386/m
od_jserv.so)
Tomcat latest from CVS and nightly builds 20000405 and 20000403

I switched back and forth between latest tomcat and tomcat-3.1b1 and
everything works fine with the latter. With the latest tomcat, I get no
answer to the browser for a while, then tomcat throws the following
exception:
----
HANDLER THREAD PROBLEM: java.io.IOException: Stream broken, couldn't
demarshal string :768:416
java.io.IOException: Stream broken, couldn't demarshal string :768:416
        at
org.apache.tomcat.service.connector.Ajpv12InputStream.readString(Ajp12Connec
tionHandler.java,
Compiled Code)
        at
org.apache.tomcat.service.connector.AJP12RequestAdapter.readNextRequest(Ajp1
2ConnectionHandler.java,
Compiled Code)
        at
org.apache.tomcat.service.connector.Ajp12ConnectionHandler.processConnection
(Ajp12ConnectionHandler.java,
Compiled Code)
        at
org.apache.tomcat.service.TcpConnectionThread.run(SimpleTcpEndpoint.java,
Compiled Code)
        at java.lang.Thread.run(Thread.java, Compiled Code)
----

I've tried to look for new jserv modules or a way to build jserv from
the source in tomcat but I didn't find anything to suggest that I am not
using the latest jserv module.

I've been looking for the Tomcat+Apache HOWTO to see if there were new
instructions, but I couldn't find it at all, has it been removed ?

Shouldn't the apache integration work in 3.1 ?

I will submit this to bugzilla, but I hope to get some response from
here first that may clarify things.

Jesper Joergensen, http://CAPUT.com

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org


Mime
  • Unnamed multipart/mixed (inline, None, 0 bytes)
View raw message