tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Remy Maucherat" <r...@exoffice.com>
Subject [Catalina] Static pages
Date Sat, 29 Apr 2000 18:55:51 GMT
> Remy Maucherat wrote:
>
> > I had a look at Catalina, and first of all, I must say I'm impressed by
how
> > clean the code is.
> > I'm still not very familiar with it, though.
>
> Thanks Remy ... I just checked in patches that include yours (some I ran
into
> yesterday as well) plus a bunch of other ones.

Yep, I saw that. I saw you fixed the setLoadOnStartup too (which shouldn't
happen anyway either).

> > Random facts :
> > - After toying a bit with the config, the DummyContainer works :-)
>
> If you start Catalina now and ask for "http://localhost:8080/index.html"
it
> should now serve you the Tomcat home page.  Today's task is to finish
cleaning
> up the default servlet and add the invoker servlet.

:-)
It works, but only the first impression of the page. If I hit refresh on my
browser, I get an error (code 304).
Here's the log (it's working now, cool :-) :
127.0.0.1 - - [29/Apr/2000:10:43:22 -0800] "GET / HTTP/1.1" 400 -
127.0.0.1 - - [29/Apr/2000:10:43:24 -0800] "GET / HTTP/1.1" 400 -
127.0.0.1 - - [29/Apr/2000:10:43:25 -0800] "GET / HTTP/1.1" 400 -
127.0.0.1 - - [29/Apr/2000:10:43:25 -0800] "GET / HTTP/1.1" 400 -
127.0.0.1 - - [29/Apr/2000:10:43:35 -0800] "GET /index.html HTTP/1.1" 304 -
127.0.0.1 - - [29/Apr/2000:10:43:36 -0800] "GET /index.html HTTP/1.1" 304 -
127.0.0.1 - - [29/Apr/2000:10:43:37 -0800] "GET /index.html HTTP/1.1" 304 -
127.0.0.1 - - [29/Apr/2000:10:43:38 -0800] "GET /index.html HTTP/1.1" 304 -
127.0.0.1 - - [29/Apr/2000:10:43:38 -0800] "GET /index.html HTTP/1.1" 304 -
127.0.0.1 - - [29/Apr/2000:10:43:45 -0800] "GET /index.html HTTP/1.1" 200
2527
127.0.0.1 - - [29/Apr/2000:10:43:45 -0800] "GET /tomcat.gif HTTP/1.1" 200
1934
127.0.0.1 - - [29/Apr/2000:10:43:47 -0800] "GET /index.html HTTP/1.1" 304 -
127.0.0.1 - - [29/Apr/2000:10:43:49 -0800] "GET /index.html HTTP/1.1" 304 -
127.0.0.1 - - [29/Apr/2000:10:44:31 -0800] "GET /index.html HTTP/1.1" 304 -
127.0.0.1 - - [29/Apr/2000:10:44:44 -0800] "GET /examples/index.html
HTTP/1.1" 200 2527
127.0.0.1 - - [29/Apr/2000:10:44:44 -0800] "GET /examples/tomcat.gif
HTTP/1.1" 200 1934
127.0.0.1 - - [29/Apr/2000:11:20:40 -0800] "GET /examples/index.html
HTTP/1.1" 304 -
127.0.0.1 - - [29/Apr/2000:11:21:10 -0800] "GET
/servlet/org.exolab.slide.webdav.Webdav HTTP/1.1" 200 -
127.0.0.1 - - [29/Apr/2000:11:21:15 -0800] "GET
/servlet/org.exolab.slide.webdav.Webdav HTTP/1.1" 200 -

304 - Not Modified, seems like it's related to that : "Still messes up on
the If-Modified-Since check".

Remy


Mime
View raw message