tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gal Shachor <>
Subject Re: M1R2, .WAR and ResourceBundle
Date Thu, 02 Mar 2000 13:57:13 GMT


Try to put your properties file inside the
webapps\<myapp>\WEB-INF\classes directory
I not sure that the webapps\<myapp>\WEB-INF should be loadable by the
class loader (look at section 9.4 of the servlet API spec).

	Gal Shachor wrote:
> I have a webapp that localizes strings via a ResourceBundle.  I've just updated
> everything to create a .WAR file, which I place in the webapps directory.  I'm
> running M1R2.
> The first time I start Tomcat, the .WAR file hasn't yet been unpacked.  It gets
> unpacked OK, but when I try to hit my URI with the browser I get:
>      java.util.MissingResourceException: Can't find resource for base name
> actionStrings, locale en_US
> The file is in the webapps\<myapp>\WEB-INF, which is in
> the classpath, but for some reason it's not found.
> The second time I start Tomcat - when all the files are already unpacked - there
> are no problems.
> Some of the servlet examples use to do about the same
> thing I'm doing.  Those examples work, but I don't see anything in their code,
> web.xml or server.xml that looks different than what I'm doing.
> Any idea what's happening?
> Thanks,
> -Jeff
> ---------------------------------------------------------------------
> To unsubscribe, e-mail:
> For additional commands, e-mail:

View raw message