tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mike Engelhart <mengelh...@earthtrip.com>
Subject Tomcat/JServ/SSL
Date Tue, 22 Feb 2000 02:38:46 GMT
I just went through the FAQ, the archives at mail-archive.com and the tomcat
archives about this and saw some threads with the same topic, but no
answers.  

here's what I have
RedHat 6.1
Apache 1.3.11
Mod_ssl 2.5.0 (compiled against OpenSSL 0.9.4)
JServ 1.1 Final
Tomcat 3.1M1 (also tried Tomcat 3.0 final)

When using Tomcat as the servlet engine behind JServ, headers don't get
passed through JServ.  Even if I start the server using ./apachectl start
instead of ./apachectl startssl, I get no header information sent through to
my servlets.   For example the RequestHeaders example servlet just returns a
blank page.  User-Agent, Accept-Language,etc.  None of these are passed
through.

I've tried recompiling everything as static and everything as DSO and
combinations thereof and nothing seems to work.
The one thing that DOES work with all of this is if I replace JServ 1.1
Final with JServ 1.1b3.  everything works fine with that release on both
Tomcat 3.0 and Tomcat 3.1M1.   I don't know how many changes occured in
between the b3 and final release but somewhere something either broke or was
fixed and broke something in Tomcat.

Any help would be appreciated.  I posted to the JServ list which was no
help.

Thanks,
Mike


Mime
View raw message