tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Cruikshank <a...@epitonic.com>
Subject Re: Problem with POST-Reqs via RequestDispatcher.forward()
Date Wed, 23 Feb 2000 17:58:52 GMT
This was a bug that was fixed in the 3.1 server.  I highly recommend 
grabbing the latest copy of it.

Alex Cruikshank


At 05:37 PM 2/23/00 +0100, you wrote:
>Hi,
>
>I've noticed some trouble in forwarding post requests with 
>Tomcat3.0/standalone
>(at NT).
>I've already seen some posts dealing with this problem but without 
>answers. I'm
>relative
>new to Tomcat but not to servlet engines / containers in general.
>
>My sample scenario is as follows:
>A servlet, say the FrontServlet, forwards every request via forward(req, 
>res) to
>another
>servlets, let's call it BackServlet. There the processing of parameters 
>will be
>done. This
>works fine. Now I want to have a FullRequestLog. Therefore I wrote a method
>which is
>parsing the parameter list and echos all to log(). If I do this in the
>FrontServlet at a post
>request before forwarding the request the log shows all params well. But if I
>want to do
>this in the BackServlet again, there are no parameters. This only happens if I
>touch the
>request parameters in the forwarding servlet and if I'm using post. In case of
>get all goes
>well. On the jswdk-1.0.1 this works without probems.
>
>Any experience or suggestions ?
>
>Thomas
>
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
>For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org


Mime
View raw message