tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Meleedy <david.mele...@analog.com>
Subject I'd like to get Tomcat 3.1 milestone 1 working for Solaris 2.6
Date Tue, 15 Feb 2000 21:58:38 GMT

I am trying to get everything working with Solaris 2.6, and jdk 1.2.1_04

At first I tried Tomcat 3.0, but when I tried to start up the tomcat
server, with jdk 1.2.1_04, the server wouldn't start up all the way
(it worked with jdk 1.1.8_10).

So now I am trying to compile 3.1 milestone 1.  I am able to
get all the java stuff compiled with build.sh (although I had to fix
the script).  But it is not clear how to build jserv_module.so

I noticed that in the binaries directory, there is a linux and a win32
binary available, but no solaris.  e.g.
http://jakarta.apache.org/builds/tomcat/release/v3.1_m1/bin/

So how exactly do I get this compiled up?  What do I have to do?

Thanks,

-Dave

p.s.  Here is what I had to change in build.sh

cp=../jakarta-ant/lib/ant.jar:../jakarta-tools/moo.jar:../jakarta-ant/lib/xml.j
ar:../build/tomcat/classes:$JAVA_HOME/lib/tools.jar

to

cp=../jakarta-tools/ant.jar:../jakarta-tools/moo.jar:../jakarta-ant/lib/xml.jar
:../build/tomcat/classes:$JAVA_HOME/lib/tools.jar


Here is what happens when I tried to run 3.0 with java 1.2.1_04

sudo ./tomcat.sh start
Using classpath: ./webserver.jar:./lib/servlet.jar:./lib/jasper.jar:./lib/xml.j
ar:/cpd/shared/modules/jdk1.2.1_04/lib/tools.jar
whitestar-11: Tomcat Web Server Version 3.0
Loaded configuration from: file:/cpd/inet/apache/tomcat/server.xml
whitestar-11: ps -ef | grep java
whitestar-12: 

But it works just fine with java 1.1.8_10

Thanks again,

-Dave

========================================================================
David Meleedy				Analog Devices, Inc.
David.Meleedy@analog.com		Three Technology Way
Phone: 781 461 3494			Norwood, MA  02062-9106  USA



Mime
View raw message