tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Brownell <davi...@pacbell.net>
Subject Re: Tomcat on IBM OS/390?
Date Sat, 20 Nov 1999 05:57:39 GMT
"Preston L. Bannister" wrote:
>  
> Result with encoding="EBCDIC-CP-US" in all *.xml and *.dtd files:

The diagnostics suggest breakage still ... as if the XML
declaration didn't take.  Specifically, as if the files
started something like

	xml ...

rather than (again, all in EBCDIC)

	<?xml ...

Try an octal dump of those modified config files ... if the
first few bytes aren't 47 6F A7 94 then it'd seem that the
XML declaration isn't correct.


> Configuring web service using "default"
> config parse: can't read config: SAXParseException: null : 1
>   msg : Character conversion error: "Unconvertible UTF-8 character beginning with 0xa7"
(line number may be too low).

Strange -- but then, parser diagnostics got mangled on the way out,
last time I needed to look at that stuff.

Costin, you never applied that patch I sent you to ensure that the
right diagnostic information got presented ... do you still have that?
I think that some of the changes over the past few weeks broke it.

For example, "default" isn't a filename ...


> Configuring web service using "file:/nsa/users/bannisp/nsa/Jakarta/build/tomcat/webpages/WEB-INF/web.xml"
> config parse: can't read config: SAXParseException: null : 1
>   msg : Character conversion error: "Unconvertible UTF-8 character beginning with 0xa7"
(line number may be too low).
> Configuring web service using "default"
> config parse: can't read config: SAXParseException: null : 1
>   msg : Character conversion error: "Unconvertible UTF-8 character beginning with 0xa7"
(line number may be too low).
> Configuring web service using "file:/nsa/users/bannisp/nsa/Jakarta/build/tomcat/examples/WEB-INF/web.xml"
> config parse: can't read config: SAXParseException: null : 1
>   msg : Character conversion error: "Unconvertible UTF-8 character beginning with 0xa7"
(line number may be too low).
> Starting tcp endpoint on 8080 with org.apache.tomcat.service.http.HttpConnectionHandler
> Starting tcp endpoint on 8007 with org.apache.tomcat.service.Ajp11ConnectionHandler
> Starting tcp endpoint on 8009 with org.apache.tomcat.service.connector.Ajp12ConnectionHandler
> Starting tcp endpoint on 8008 with org.apache.tomcat.service.connector.Ajp23ConnectionHandler
> ---
> 
> It's running!!

... but I wonder if it's using some compiled-in default instead of
anything you gave it.

Mime
View raw message