tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Anil K. Vijendran" <...@eng.sun.com>
Subject Re: problem building ANT
Date Mon, 18 Oct 1999 08:55:18 GMT
James Davidson wrote:

> > How can the javac.jar built for JDK 1.2 work on a JDK 1.1.x system?
>
> Good question. The Sun/ASF Agreement notes that the tools.jar is allowed to
> be redistributed by apache (although only under a special provision that
> anybody who accepts it understands that it is subject to Sun's license).
> I'll have to check to see what the exact wording of the agreement is and see
> if we can roll back to a 1.1 version of the compiler.

I don't understand the issue, James. sun.tools.javac.* is included in
classes.zip for JDK 1.1. tools.jar is only necessary for 1.2. My understanding
was that we use tools.jar when the users' environment is JDK 1.2 and for 1.1 we
just expect classes.zip. Right?

>
>
> .duncan
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org

--
Peace, Anil +<:-)



Mime
View raw message