tiles-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mick Semb Wever <...@apache.org>
Subject Re: OptionsRenderer not working
Date Mon, 28 Oct 2013 17:59:24 GMT
ClamAV 0.96.5


> I'm not sure if I am happy or sad to hear that after the numerous
> hours I've spent trying to track this down! :)  

Well it was only today we got pass the cascade="true" hindrance and to
the IllegalArgumentException. But still i should have given you the
correct reply straight away and saved you 16hrs!


> In the meantime, I wrote up a hacky Aspect to intercept the
> RuntimeException and throw the cause instead when OptionRenderer is
> the caller.  

I'll be interested in anything you think makes life easier to debug such
problems. I know OptionsRenderer can too easily mask the underlying
problems.


> Can you please update your Blog with the relevant information in the
> meantime?  ie: ensuring the "cascade=true" is present in the
> list-attributes and indicate that it requires 3.0.2-SNAPSHOT at the
> minimum to be functional?

Done for cascade=true.
The article afaik doesn't refer anywhere to specific tiles-3 artifacts,
so i'd like to leave it to the reader that they should use the latest
available and get tiles-3.0.2 out quickly. (I have to get tiles-master-6
out first).


> Finally, I ran into one last problem with your Blog example, but don't
> want to pollute this thread with cross references.  Will create
> another thread with the problem.

I really appreciate your feedback Eric. Keep it coming!
I'll look into setting up a simple working example on github too.

~mck

-- 
"Do not seek to follow in the footsteps of those of old - seek what they
sought." Matsuo Basho 

| http://github.com/finn-no | http://tech.finn.no |


Mime
View raw message