tiles-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nicolas LE BAS <m...@nlebas.net>
Subject Re: Tiles CSS problem
Date Fri, 04 May 2012 18:20:52 GMT
Any reason to blame it on Tiles?

The word "tiles" doesn't appear even once in your report, and the stack 
trace you've posted says "Struts Problem"...

If /app/js/common.js gets processed by Struts and you don't want that, 
perhaps you should look at your Struts configuration. Or ask the struts 
team for help...

On 12-05-04 12:01 PM, James Soper wrote:
> Thanks for the quick reply. Any reason for that?
>
> On Fri, May 4, 2012 at 1:57 AM, Antonio Petrelli
> <antonio.petrelli@gmail.com>  wrote:
>> Not a Tiles problem I suppose...
>>
>> 2012/5/4 James Soper<soper.j@gmail.com>
>>
>>> Hi,
>>> I'm having an issue with adding css&  javascript files to my tiles.
>>> in my layout.jsp file I use these lines to add them:
>>> <link href="<s:url value="/css/common.css"/>" rel="stylesheet"
>>> type="text/css" />
>>> <script type="text/javascript" src="<s:url
>>> value="/js/common.js"/>"></script>
>>>
>>> and they're rendered in the html as:
>>> <link type="text/css" rel="stylesheet" href="/app/css/common.css">
>>> <script src="/app/js/common.js" type="text/javascript">
>>>
>>> and when I got to look at either I get:
>>> There is no Action mapped for namespace / and action name common.css(/.js)
>>> error
>>> It seems like it's trying to render both as pages.
>>>
>>> Any ideas?
>>> Thanks.
>>>


Mime
View raw message