tiles-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rick Carback <rick.carb...@gmail.com>
Subject Re: questions about web.xml
Date Wed, 14 Jan 2009 14:26:26 GMT
OK, so changing any of the paths and trying to deploy causes an error. Paths
must be correct..

Removing dispatch causes the script to error out with:

HTTP ERROR: 500

TilesContainer not initialized

RequestURI=/emws/tiles.jsp
Caused by:

javax.servlet.jsp.JspException: TilesContainer not initialized
	at org.apache.tiles.jsp.taglib.ContainerTagSupport.doStartTag(ContainerTagSupport.java:72)
	at org.apache.tiles.jsp.taglib.RenderTagSupport.doStartTag(RenderTagSupport.java:141)
	at org.apache.jsp.tiles_jsp._jspx_meth_tiles_005finsertDefinition_005f0(tiles_jsp.java:103)
	at org.apache.jsp.tiles_jsp._jspService(tiles_jsp.java:77)
	at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:70)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:806)
	at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:369)
	at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:342)
	at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:267)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:806)
	at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:487)
	at org.apache.geronimo.jetty6.InternalJettyServletHolder.handle(InternalJettyServletHolder.java:65)
	at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:362)
	at org.mortbay.jetty.security.SecurityHandler.handle(SecurityHandler.java:216)
	at org.mortbay.jetty.servlet.SessionHandler.handle(SessionHandler.java:181)
	at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandler.java:726)
	at org.mortbay.jetty.webapp.WebAppContext.handle(WebAppContext.java:405)
	at org.apache.geronimo.jetty6.handler.TwistyWebAppContext.access$101(TwistyWebAppContext.java:40)
	at org.apache.geronimo.jetty6.handler.TwistyWebAppContext$TwistyHandler.handle(TwistyWebAppContext.java:65)
	at org.apache.geronimo.jetty6.handler.ThreadClassloaderHandler.handle(ThreadClassloaderHandler.java:46)
	at org.apache.geronimo.jetty6.handler.InstanceContextHandler.handle(InstanceContextHandler.java:58)
	at org.apache.geronimo.jetty6.handler.UserTransactionHandler.handle(UserTransactionHandler.java:48)
	at org.apache.geronimo.jetty6.handler.ComponentContextHandler.handle(ComponentContextHandler.java:47)
	at org.apache.geronimo.jetty6.handler.TwistyWebAppContext.handle(TwistyWebAppContext.java:59)
	at org.mortbay.jetty.handler.ContextHandlerCollection.handle(ContextHandlerCollection.java:206)
	at org.mortbay.jetty.handler.HandlerCollection.handle(HandlerCollection.java:114)
	at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:139)
	at org.mortbay.jetty.Server.handle(Server.java:324)
	at org.mortbay.jetty.HttpConnection.handleRequest(HttpConnection.java:505)
	at org.mortbay.jetty.HttpConnection$RequestHandler.headerComplete(HttpConnection.java:828)
	at org.mortbay.jetty.HttpParser.parseNext(HttpParser.java:514)
	at org.mortbay.jetty.HttpParser.parseAvailable(HttpParser.java:211)
	at org.mortbay.jetty.HttpConnection.handle(HttpConnection.java:380)
	at org.mortbay.io.nio.SelectChannelEndPoint.run(SelectChannelEndPoint.java:395)
	at org.apache.geronimo.pool.ThreadPool$1.run(ThreadPool.java:214)
	at org.apache.geronimo.pool.ThreadPool$ContextClassLoaderRunnable.run(ThreadPool.java:344)
	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:650)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:675)
	at java.lang.Thread.run(Thread.java:613)

*Powered by Jetty:// <http://jetty.mortbay.org/>*
Adding dispatch in makes the code work. None of the code is using the
dispatch to my knowledge (because it's a copy/paste of the example tutorial
that simply uses the classic.jsp which includes other .jsps).

I attached the log file captures for both with and without the classic. Any
ideas? It seems that you need dispatch to get it to work (with geronimo
v2.1) even if you aren't using dispatch..then again, maybe i'm using
dispatch and not realizing it.. Would using dispatch cause a "TilesContainer
not initialized" error if it were not included in web.xml? Note that in both
logs Tiles2 initialization completes.

All that said, this thing is great once you get it working.

Let me see if I can reproduce this in a smaller project and zip it up for
you..

-R




On Wed, Jan 14, 2009 at 7:55 AM, Antonio <antonio.petrelli@gmail.com> wrote:

> 2009/1/14 Richard Carback <rick.carback@gmail.com>:
> > If any of the paths I specified are changed then I always get an error,
> so I
> > am reasonably sure they are correct. Would it be possible to have bad
> paths
> > and still get a functional setup with the other two statements (I guess
> > dispatch servlet loads the tiles servlet?)?
>
> Sincerely I never tried it, but I guess no.
>
> > I did not see errors with either of the web.xml files when browsing
> through
> > "geronimo.log," but I can go back and get a capture of the entire log for
> > you right after deployment with and without the statements if that's
> helpful
> > to you.
>
> Ok.
>
> > What perplexes me about this situation is that I'm not using (or even
> > wanting to use) the *.tiles. I assume I must be doing something wrong and
> > just stupidly missing it.
>
> Then remove the TilesDispatchServlet. Only TilesServlet is necessary
> to bootstrap Tiles.
>
> Antonio
>

Mime
  • Unnamed multipart/mixed (inline, None, 0 bytes)
View raw message