tiles-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Adam Hardy <ahardy.str...@cyberspaceroad.com>
Subject ClassNotFoundException StrutsTilesListener
Date Tue, 07 Oct 2008 14:24:49 GMT
Error configuring application listener of class 
org.apache.struts2.tiles.StrutsTilesListener

I was working away happily until I decided a couple of hours ago to upgrade from 
Tiles 2.0.4 to 2.0.6 and from Struts 2.0.9 to 2.0.11.2

However now I get the above error.

I have now checked over my configuration and projects and classpaths and can't 
find any reason - the struts2-tiles-plugin-2.0.11.2 is there and it contains 
org.apache.struts2.tiles.StrutsTilesListener as configured by my web.xml as a 
listener!

I can't figure out what it is although I guess it must be something flakey to do 
with the tomcat eclipse plug-in, or maybe an old tiles or struts jar lying 
around where it should be anymore.

Anyone have any tips?


Thanks
Adam


Mime
View raw message