tiles-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Antonio Petrelli" <antonio.petre...@gmail.com>
Subject Re: Tiles with Struts2 and Portlet2
Date Fri, 19 Sep 2008 13:47:34 GMT
Wow! This is way too complex! And probably Tiles has nothing to do with it.
Try asking the Struts users mailing list (sorry for the second redirection):
http://struts.apache.org/mail.html

Probably someone will then ask you to create a JIRA issue attaching a
test case, so be prepared :-D

Ciao
Antonio

2008/9/19 Max Gréau <greaumaxime@gmail.com>:
> Hi,
>
> We are developing a portlet 2.0 application (with struts 2.1.2) which is
> deployed on a jboss-portlet-container-tomcat6.
> It works fine with basic actions and JSP, but we have some problems when we
> try to use tiles:
>
> We use the struts2-tiles-plugin with this patch
> https://issues.apache.org/struts/browse/WW-2682.
> It works with basic tiles (a layout with simple menu.jsp and body.jsp)
>
> But we have troubles when we try to use :
> - the TilesDecorationFilter : we follow the TILES-228 issue (
> https://issues.apache.org/struts/browse/TILES-228) but the home.jsp is
> rendered without the decorator
> OR
>
> - the validation framework with tiles : without tiles, validators work fine
> in the portlet. But when we activate tiles, it doesn't work anymore when the
> validator try to display the form with errors messages : an action phase is
> executed but what the validator want to execute isn't allowed in a action
> phase but only in a render phase.
>
> Could you help us please ?
> Do you have examples like that ?
> Thanks.
>
> Regards,
>
> Maxime.
>

Mime
View raw message