tiles-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bipin Sadhwani <bksadhw...@yahoo.com>
Subject nested tiles problem
Date Mon, 08 Sep 2008 15:10:46 GMT
Hi everyone,
I have this wierd issue with tiles. Probably its a bug. 
My environment is:  Windows XP Professional, MyEclipse 6.0.1, Struts 2.0.6, Tiles 2.0.6, J2EE
1.4, JDK 5.0, JBoss 4.2.2
I am trying to insert a tile (a jsp page) into another tile (a jsp page) and so this is my
config (simplified): 
      
    tiles.xml 
    --------- 
      
    <definition name="rootPage.index" template="layout.jsp"> 
     <put-attribute name="pagetitle" value="Page Body Title" /> 
     <put-attribute name="header" value="header.jsp" /> 
     <put-attribute name="footer" value="footer.jsp" /> 
    </definition> 
      
    <definition name="searchEmployee.index" extends="rootPage.index"> 
     <put-attribute name="body" value="searchEmpBody.index" /> 
     </definition> 
    <definition name="searchEmpBody.index" 
     template="/searchEmployee.jsp"/> 
    </definition> 
      
    <definition name="status.index" template="/status.jsp"> 
    </definition> 
      
    layout.jsp 
    ----------- 
      
    <body> 
        <div class="container"> 
     <div id="header"> 
     <tiles:insertAttribute name="header" /> 
     </div> 
    
     <div id="mainContent"> 
     <tiles:insertAttribute name="body" /> 
     </div> 
        </div> 
    </body> 

Now following are the things I try on my searchEmployee.jsp 
      
searchEmployee.jsp - This works 

    <%@ taglib prefix="tiles" uri="http://tiles.apache.org/tags-tiles";%> 
    <%@ taglib prefix="s" uri="/struts-tags" %> 
      
    <tiles:insertDefinition name="status.index"/> 

searchEmployee.jsp - This also works 

    <%@ taglib prefix="tiles" uri="http://tiles.apache.org/tags-tiles";%> 
    <%@ taglib prefix="s" uri="/struts-tags" %> 
      
    <s:form action="listEmployees"> 
     <tiles:getAsString name="pagetitle"/> 
    </s:form> 

searchEmployee.jsp - This does work (only if I use tiles:insertDefinition below s:form) 

    <%@ taglib prefix="tiles" uri="http://tiles.apache.org/tags-tiles";%> 
    <%@ taglib prefix="s" uri="/struts-tags" %> 
      
    <s:form action="listEmployees"> 
    </s:form> 

<tiles:insertDefinition name="status.index"/> 

searchEmployee.jsp - This does NOT work (if I use tiles:insertDefinition above or within s:form
things don't work) 

    <%@ taglib prefix="tiles" uri="http://tiles.apache.org/tags-tiles";%> 
    <%@ taglib prefix="s" uri="/struts-tags" %> 
      
    <s:form action="listEmployees"> 
     <tiles:insertDefinition name="status.index"/> 
    </s:form> 

I get a long exception stack trace which basically says nullptrexception. 

I've done the same thing using tiles1.x and it has always worked. 

Tks
Bipin


Mime
View raw message