tiles-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Antonio Petrelli" <antonio.petre...@gmail.com>
Subject Re: Struts2 Tiles and UTF-8
Date Thu, 14 Feb 2008 09:58:52 GMT
Please upgrade to Tiles 2.0.5 and let us know:
http://tiles.apache.org/download.html

Antonio

2008/2/14, Pedro-1 <pierre_leplus@hotmail.fr>:
>
>
> Dear Tiles specialists,
> I have a JSP file with the following content:
> ====== sameFile.jsp ===
> <%@ page contentType="text/html;charset=UTF-8" pageEncoding="UTF-8"
> language="java" %>
> <%@ taglib uri="http://tiles.apache.org/tags-tiles" prefix="tiles" %>
> <%@ taglib prefix="s" uri="/struts-tags" %>
> <html>
> <head>
>         <meta http-equiv="Content-Language" content="fr,en" />
>                 <meta content="text/html; charset=UTF-8"
> http-equiv="content-type">
> </head>
> <body>
> Déconnexion, à é
> ....
> ======
> If it is used directly as a struts result, the browser display correctly
> the
> accentuated characters, but If It used as tiles type through a tiles page,
> the accentuated chars are converted to ISO-8859. and wrongly displayed by
> the browser that expect UTF-8.
> Any idea of what is wrong here?
> ====== tiles.xml ===
> <?xml version="1.0" encoding="UTF-8" ?>
> <!DOCTYPE tiles-definitions PUBLIC
>         "-//Apache Software Foundation//DTD Tiles Configuration 2.0//EN"
>         "http://struts.apache.org/dtds/tiles-config_2_0.dtd">
> <tiles-definitions>
>     <definition name="sameFile.page" template="sameFile.jsp">
>    </definition>
> </tiles-definitions>
> ==========
> I use tiles-api-2.0 and tiles-core-2.0
> Thanks in advance for your help
>
>
> --
> View this message in context:
> http://www.nabble.com/Struts2-Tiles-and-UTF-8-tp15476505p15476505.html
> Sent from the tiles users mailing list archive at Nabble.com.
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message