tiles-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Antonio Petrelli" <antonio.petre...@gmail.com>
Subject Re: Tiles2 / Strus2 using an action's output as template
Date Tue, 12 Feb 2008 13:39:51 GMT
2008/2/12, Daniel Baldes <db@open.ch>:
>
> Hi Antonio,
>
> thanks for your reply,
>
> > Since you did not provide a version of Tiles, I am assuming that you
> > are using Tiles 2.0.5.
> > There was a fix, and it will appear in Tiles 2.0.6. Try building it
> > from source, by downloading the trunk of Tiles.
>
> Sorry, right, it was 2.0.5. I have just checked out and built
> tiles-2.0.6-SNAPSHOT. Unfortunately, the problem persists.
>
> I am using struts 2.0.11 w/ tiles plugin, now tiles-2.0.6-SNAPSHOT
> (core, api and jsp jar), java 1.6.0_03, tomcat 6.0.16 and servlet api 2.5.
>
> I have put together a simple example which reproduces the problem:
> http://baldes.name/s2t2.tar.gz  This is a packed eclipse wtp "dynamic
> web project" containing all needed libraries and files (~5mb) (that is,
> all but apache tomcat itself).
>
> Calling http://server/context/some.action yields the problem I described.
>
> This is the stacktrace I get: http://baldes.name/s2t2.stacktrace.txt



I think it is a Struts 2/Tiles 2 plugin bug, not of Tiles itself, since the
Struts 2 filter is called, but the request seems not being put.
Please file an issue at:
https://issues.apache.org/struts/browse/WW
with the "Plugin - Tiles" component.

Antonio

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message