tiles-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Wendy Smoak <wsm...@gmail.com>
Subject Re: Bump Tiles to build with minimum JDK 1.8 ?
Date Mon, 04 Sep 2017 20:58:26 GMT
I have not been following things that closely.  I usually look to
Apache Commons when trying to decide these things, but they don't call
out platform level changes in their doc:
https://commons.apache.org/releases/versioning.html

But yes, I think it means Tiles 4.x if you are going to require that
users upgrade their Java version in order to upgrade from Tiles 3.x,
because it implies that you are going to use some new language
features that would make Tiles "not interface compatible with the
prior version."

This has long been a point of contention, with framework developers
wanting to use the latest and greatest, but framework users having
more barriers to upgrading. :)

--
Wendy

On Mon, Sep 4, 2017 at 4:37 PM, mck <mck@apache.org> wrote:
>
>
> On Mon, 4 Sep 2017, at 22:36, Antonio Petrelli wrote:
>> Hello
>> sorry to bump here, but I think a major version should be released with
>> such an important change.
>
>
> Yes, good idea.
> If there's no other objections then I'll apply the master pom updates
> onwards to major versions.
>
> That means:
>   tiles-autotag-2.0-SNAPSHOT
>   tiles-request-2.0-SNAPSHOT
>   tiles-4.0-SNAPSHOT
>
>
>  Antonio and Wendy, I presume that you didn't mean simply not patch
>  versions, ie bumping to
>   tiles-autotag-2.3-SNAPSHOT
>   tiles-request-1.1-SNAPSHOT
>   tiles-3.1-SNAPSHOT
>
> regards,
> Mick

Mime
View raw message