tiles-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Antonio Petrelli <antonio.petre...@gmail.com>
Subject Re: Bump Tiles to build with minimum JDK 1.8 ?
Date Wed, 06 Sep 2017 10:48:21 GMT
2017-09-06 12:39 GMT+02:00 mck <mck@apache.org>:

>
> > I don't get one thing first of all. Why not moving to *all* Java 8
> > without
> > the hassle of compiling with a platform and retrofitting to another?
> > What is the purpose of such a move?
> >
>
>
> So that compatibility of build tools is narrower than that of runtime.
>
> One example is what java and maven versions apache's jenkins
> infrastructure supports imposes different constraints as to what are
> user base does.
> Also we can provide a standard secured build tool set over multiple
> branches that offer different runtime compatibilities.
> Like knowing I don't have to go find JDK1.7 to build and test before
> committing (or like having different jenkins builds to ensure we can
> build on both Java7 and Java8, etc etc)
>
>
So you are telling me that the only reason to change JRE requirements are
build tools?
I am the last one to tell you to stop (I am emeritus after all and wanting
to stay), but I suggest not to do such a move. If your reasons are better,
like moving to new Java 7 or 8 features at least for new code, I'm all for
it.
But build tools, come on...

Antonio

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message