tiles-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From mck <...@apache.org>
Subject Re: Bump Tiles to build with minimum JDK 1.8 ?
Date Wed, 06 Sep 2017 12:56:25 GMT

> Well not exactly. I know that one case is not part of statistics, however
> we use Tiles (in a Spring environment) under Java 6.


Antonio (& Wendy)'s sentiment is correct here.
As an open source project we need to honour compatibility and make api
changes according to semantic versioning rules.
A lot of production environments are old and or legacy, and security
updates required infrequently.

At the same time Brett, I do think it's time that we do AutoTag-2,
Request-2, and Tiles-4, putting them onto Java8.
It's more important at this point in time to be attracting, to our head
of development, new developers than new users. Users that need Java7
still have that option ofc w/ the current versions.

Antonio, what version of Tiles are you running on Java6?
And do you have Java8 installed on your development machine/laptop?

regards,
Mick

Mime
View raw message