tika-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gary Karasiuk (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (TIKA-966) org.apache.tika.Tika missing from tika-bundle-1.2.jar
Date Thu, 02 Aug 2012 14:45:03 GMT

    [ https://issues.apache.org/jira/browse/TIKA-966?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13427355#comment-13427355

Gary Karasiuk commented on TIKA-966:

FYI - I created this bug report:

to determine if this is an Eclipse problem. This bug report contains my testcase as an attachment.
> org.apache.tika.Tika missing from tika-bundle-1.2.jar
> -----------------------------------------------------
>                 Key: TIKA-966
>                 URL: https://issues.apache.org/jira/browse/TIKA-966
>             Project: Tika
>          Issue Type: Bug
>          Components: packaging
>    Affects Versions: 1.2
>            Reporter: Gary Karasiuk
> In version 0.9 I was able to use the org.apache.tika.Tika class in my OSGi application
simply by including the tika-bundle.
> I am now trying to move to version 1.2 and this class is missing from the tika-bundle-1.2.jar
> The top level documentation says "Tika bundle. An OSGi bundle that includes everything
you need to use all Tika functionality in an OSGi environment." so I think that this should
be continued to included.
> I tried including the tika-core-1.2.jar into my application, but even after fiddling
with various start levels I can't get the Tika class to find the parsers in the tika-bundle.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira


View raw message