thrift-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Fedor Korotkiy (Jira)" <j...@apache.org>
Subject [jira] [Commented] (THRIFT-4685) Support the new golang modules (1.11 or later)
Date Tue, 15 Dec 2020 11:12:00 GMT

    [ https://issues.apache.org/jira/browse/THRIFT-4685?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17249628#comment-17249628
] 

Fedor Korotkiy commented on THRIFT-4685:
----------------------------------------

Global versioning would be imprecise. It would introduce new versions, when it is not required.
I really think, that go api would benefit from separate import path versioning, not tied to
global thrift version. 

 

Proposed approach should not require too much work, as example repository demonstrates. And
it works in existing thrift repository. You can even refer to thrift repository tags, using
"+incompatible" version syntax in go.mod file.

> Support the new golang modules (1.11 or later)
> ----------------------------------------------
>
>                 Key: THRIFT-4685
>                 URL: https://issues.apache.org/jira/browse/THRIFT-4685
>             Project: Thrift
>          Issue Type: Improvement
>          Components: Go - Library
>    Affects Versions: 0.12.0
>         Environment: golang 1.11 or later
>            Reporter: James E. King III
>            Assignee: Duru Can Celasun
>            Priority: Minor
>
> Go added new module support in 1.11, see:
> https://github.com/golang/go/wiki/Modules
> We should move towards it.



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

Mime
View raw message