thrift-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Zezeng Wang (Jira)" <j...@apache.org>
Subject [jira] [Updated] (THRIFT-5312) The Ruby compilation configuration in the .gemspec file is modified to be compatible with later bundler versions.
Date Mon, 16 Nov 2020 13:04:00 GMT

     [ https://issues.apache.org/jira/browse/THRIFT-5312?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Zezeng Wang updated THRIFT-5312:
--------------------------------
    Description: 
If use the version laster to build the ruby lib will fail by a error like this:
{code}
/usr/lib/ruby/vendor_ruby/rubygems/defaults/operating_system.rb10: warning: constant Gem::ConfigMap
is deprecated.
{code}


Want to be compatible with the new *bundler* version.

>From the content in the link, there is no problem.
[semver|https://semver.org]

  was:
If use the version laster to build the ruby lib will fail by a error like this:
{code}
/usr/lib/ruby/vendor_ruby/rubygems/defaults/operating_system.rb10: warning: constant Gem::ConfigMap
is deprecated.
{code}


Want to be compatible with the new *bundler* version.

It's no problem to refer to the link.
[semver|https://semver.org]


> The Ruby compilation configuration in the .gemspec file is modified to be compatible
with later bundler versions.
> -----------------------------------------------------------------------------------------------------------------
>
>                 Key: THRIFT-5312
>                 URL: https://issues.apache.org/jira/browse/THRIFT-5312
>             Project: Thrift
>          Issue Type: Improvement
>          Components: Ruby - Library
>            Reporter: Zezeng Wang
>            Assignee: Zezeng Wang
>            Priority: Major
>          Time Spent: 10m
>  Remaining Estimate: 0h
>
> If use the version laster to build the ruby lib will fail by a error like this:
> {code}
> /usr/lib/ruby/vendor_ruby/rubygems/defaults/operating_system.rb10: warning: constant
Gem::ConfigMap is deprecated.
> {code}
> Want to be compatible with the new *bundler* version.
> From the content in the link, there is no problem.
> [semver|https://semver.org]



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

Mime
View raw message