thrift-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jens Geyer (Jira)" <j...@apache.org>
Subject [jira] [Commented] (THRIFT-5182) Disable VS2015 in favor of VS2019?
Date Wed, 22 Apr 2020 19:11:00 GMT

    [ https://issues.apache.org/jira/browse/THRIFT-5182?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17089956#comment-17089956
] 

Jens Geyer commented on THRIFT-5182:
------------------------------------

I'm fine with it, if that is the question :-) The unwritten policy is that whatever is mainstream
is good. Sometimes there are some requirenents from poeple that use older platforms but I
guess whoever is using VS does it on a more or less professional basis, hence 2019 is state
of the art. 

All personal opinion, of course. Other people may have different views.

> Disable VS2015 in favor of VS2019?
> ----------------------------------
>
>                 Key: THRIFT-5182
>                 URL: https://issues.apache.org/jira/browse/THRIFT-5182
>             Project: Thrift
>          Issue Type: Improvement
>          Components: Build Process
>    Affects Versions: 0.13.0
>            Reporter: Mario Emmenlauer
>            Priority: Minor
>
> Currently the builds still use Visual Studio 2015. Would it be time to deprecate 2015
and move to Visual Studio 2019? Supposedly AppVeyor already supports VS2019 (https://www.appveyor.com/updates/
lists #3379 Visual Studio 2019 version 16.5.4).
> Or is there a reason / policy that suggests specific versions to keep? Anyone still requiring
VS2015?



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

Mime
View raw message