thrift-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jens Geyer (Jira)" <j...@apache.org>
Subject [jira] [Resolved] (THRIFT-3153) Feather logo not shown in IE (but on staging site)
Date Mon, 27 Jan 2020 09:39:00 GMT

     [ https://issues.apache.org/jira/browse/THRIFT-3153?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jens Geyer resolved THRIFT-3153.
--------------------------------
      Assignee: Jens Geyer
    Resolution: Won't Do

IE is no longer much of an issue, so let's just close this.

> Feather logo not shown in IE (but on staging site)
> --------------------------------------------------
>
>                 Key: THRIFT-3153
>                 URL: https://issues.apache.org/jira/browse/THRIFT-3153
>             Project: Thrift
>          Issue Type: Bug
>          Components: Website
>         Environment: IE 11 on Windows 8.1
>            Reporter: Jens Geyer
>            Assignee: Jens Geyer
>            Priority: Major
>         Attachments: problem.png
>
>
> The Apache Feather logo looks broken in IE when looking at the public web site, but is
shown correctly at the staging site. 
> Links to check: 
>  * https://thrift.apache.org/static/images/favicon.ico
>  * http://thrift.staging.apache.org/static/images/favicon.ico 
> A possible reason is the MIME type which the web server delivers to the browser. The
staging site delivers the favicon.ico as {{image/x-icon}}, but the public website as {{image/vnd.microsoft.icon}}.
Ironically, the latter seems not to be understand by IE, as [this SO posting seems to confirm|http://stackoverflow.com/a/28300054/499466].
> *Conclusion:* 
> We should change the MIME type to {{image/x-icon}} to match the staging site.



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

Mime
View raw message