thrift-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rocco Corsi (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (THRIFT-4910) ./configure: line 14116: syntax error near unexpected token `QT5,'
Date Tue, 23 Jul 2019 19:51:00 GMT

    [ https://issues.apache.org/jira/browse/THRIFT-4910?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16891328#comment-16891328
] 

Rocco Corsi edited comment on THRIFT-4910 at 7/23/19 7:50 PM:
--------------------------------------------------------------

I found this in ./doc/install/windows.md

### Possible issues with Cygwin install

See also Possible issues with MinGW install.

#### Syntax error in ./configure

The following error occurs for some users when running ./configure:

        ./configure: line 21183: syntax error near unexpected token `MONO,'
         ./configure: line 21183: `  PKG_CHECK_MODULES(MONO, mono >= 1.2.6, have_mono=yes,
have_mono=no)'

To resolve this, you'll need to find your pkg.m4 (installed by the pkg-config package) file
and copy it to the thrift/aclocal directory.  From the top-level thrift directory, you can
copy the file by running

        cp /usr/share/aclocal/pkg.m4 aclocal

Finally, re-run ./bootstrap.sh and ./configure.  (Note that pkg.m4 is created by the pkg-config
tool.  If your /usr/share/aclocal directory doesn't contain the pkg.m4 file, you may not
have pkg-config installed.)
{noformat}
*no* further _formatting_ is done here{noformat}


was (Author: roccocorsi):
I found this in ./doc/install/windows.md

### Possible issues with Cygwin install

See also Possible issues with MinGW install.

#### Syntax error in ./configure

The following error occurs for some users when running ./configure:

        ./configure: line 21183: syntax error near unexpected token `MONO,'
         ./configure: line 21183: `  PKG_CHECK_MODULES(MONO, mono >= 1.2.6, have_mono=yes,
have_mono=no)'

To resolve this, you'll need to find your pkg.m4 (installed by the pkg-config package) file
and copy it to the thrift/aclocal directory.  From the top-level thrift directory, you can
copy the file by running

        cp /usr/share/aclocal/pkg.m4 aclocal

Finally, re-run ./bootstrap.sh and ./configure.  (Note that pkg.m4 is created by the pkg-config
tool.  If your /usr/share/aclocal directory doesn't contain the pkg.m4 file, you may not
have pkg-config installed.)

> ./configure: line 14116: syntax error near unexpected token `QT5,'
> ------------------------------------------------------------------
>
>                 Key: THRIFT-4910
>                 URL: https://issues.apache.org/jira/browse/THRIFT-4910
>             Project: Thrift
>          Issue Type: Question
>          Components: Build Process
>    Affects Versions: 0.13.0
>         Environment: Ubuntu 19.04
>            Reporter: Rocco Corsi
>            Priority: Minor
>         Attachments: config.log, configure.out.txt, console.txt, console_20190723_1436.txt
>
>
> Testing build of latest master branch on Ubuntu 19.04
> Failing on configure
> ...
> checking whether yytext is a pointer... yes
> checking whether ln -s works... yes
> checking for gawk... (cached) mawk
> checking for ranlib... (cached) ranlib
> checking whether g++ supports C++11 features with -std=c++11... yes
> ./configure: line 14116: syntax error near unexpected token `QT5,'
> ./configure: line 14116: `    PKG_CHECK_MODULES(QT5, Qt5Core >= 5.0, Qt5Network
>= 5.0,'
> Might there be something wrong in my environment, wrong version of something (e.g. I
have automake 1.16.1-4)
>  
> Attached my console log output and config.log file. 
>  
> Current commit:
> commit 4c847372eb9af8ec0b21ace31840eaabfdf32660 (HEAD -> master, origin/master, origin/HEAD)
> Author: guozhu cheng <bengol@163.com>
> Date:   Mon Jul 15 19:46:25 2019 +0800
>     THRIFT-4908: remove reader&writer in Golang's TBinaryProtocol
>     
>     Client: go
>     
>     This closes #1831.



--
This message was sent by Atlassian JIRA
(v7.6.14#76016)

Mime
View raw message