thrift-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James E. King III (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (THRIFT-4793) Drop PHP support for versions before 7.1
Date Fri, 15 Feb 2019 01:20:00 GMT

     [ https://issues.apache.org/jira/browse/THRIFT-4793?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

James E. King III updated THRIFT-4793:
--------------------------------------
    Description: 
Support for PHP 7.1 ended December 2018  Security support runs until DEC 2019.
All PHP development should be on PHP 7.2 or later.
phpunit version 8 is the current version and we're using 4.8.  phpunit8 requires PHP 7.2.
phpunit7 requires php 7.1 and has fewer breaking changes.

These changes will drop support for PHP < 7.1.  Ubuntu xenial build job will stop building
php.
Folks who need PHP support for versions before 7.1 can use version 0.12.0 which is already
released.
The code may actually work, but we should keep up with the ecosystem.

  was:
Support for PHP 7.1 ended December 2018.
All PHP development should be on PHP 7.2 or later.
phpunit version 8 is the current version and we're using 4.8.

These changes will drop support for PHP < 7.2.
Folks who need PHP support for versions before 7.2 can use version 0.12.0 which is already
released.


> Drop PHP support for versions before 7.1
> ----------------------------------------
>
>                 Key: THRIFT-4793
>                 URL: https://issues.apache.org/jira/browse/THRIFT-4793
>             Project: Thrift
>          Issue Type: Improvement
>          Components: PHP - Library
>    Affects Versions: 0.12.0
>            Reporter: James E. King III
>            Assignee: James E. King III
>            Priority: Major
>              Labels: Breaking-Change
>
> Support for PHP 7.1 ended December 2018  Security support runs until DEC 2019.
> All PHP development should be on PHP 7.2 or later.
> phpunit version 8 is the current version and we're using 4.8.  phpunit8 requires PHP
7.2.
> phpunit7 requires php 7.1 and has fewer breaking changes.
> These changes will drop support for PHP < 7.1.  Ubuntu xenial build job will stop
building php.
> Folks who need PHP support for versions before 7.1 can use version 0.12.0 which is already
released.
> The code may actually work, but we should keep up with the ecosystem.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message