thrift-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James E. King III (JIRA)" <j...@apache.org>
Subject [jira] [Created] (THRIFT-4724) dlang dub.json dependency for openssl is too restrictive
Date Sat, 05 Jan 2019 14:30:00 GMT
James E. King III created THRIFT-4724:
-----------------------------------------

             Summary: dlang dub.json dependency for openssl is too restrictive
                 Key: THRIFT-4724
                 URL: https://issues.apache.org/jira/browse/THRIFT-4724
             Project: Thrift
          Issue Type: Bug
          Components: D - Library
    Affects Versions: 0.12.0
            Reporter: James E. King III
            Assignee: James E. King III


In reviewing the dub.json file it specifies this deimos openssl dependency:
{noformat}
    "openssl": {
      "version": "~>1.1.6"
    }
{noformat}

This limits package dependencies to native OpenSSL 1.0 systems only.  The correct dependency
should be:
{noformat}
    "openssl": {
      "version": ">=1.1.6"
    }
{noformat}

This allows the consumer to use either the v1.1.6 (OpenSSL 1.0 compatible) or v2.0.0 (OpenSSL
1.1 compatible) version of the OpenSSL deimos package.

The `systemDependencies` field should be updated to reflect this as well.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message