thrift-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Randy Abernethy ...@apache.org>
Subject Re: golang support pre-1.8 discussion
Date Thu, 19 Oct 2017 21:13:24 GMT
I agree with Jim and Jens. It is hard to move Thrift forward if we have to
support language versions that the language maintainers do not support. To
rationalize this, if you are using old Go, you should also be ok using old
Thrift. I am strongly in favor of not supporting versions of languages that
the language maintainers do not support.

-Randy

On Thu, Oct 19, 2017 at 2:06 PM, Jens Geyer <jensgeyer@hotmail.com> wrote:

>
> Funny enough, that's basically what I said only a few weeks ago. But then
> very quickly a few people showed up and said they would need pre 1.7 ...
> mmmh.
>
>
> -----Urspr√ľngliche Nachricht-----
> From: James E. King, III
> Sent: Thursday, October 19, 2017 10:51 PM
> To: dev@thrift.apache.org
> Subject: golang support pre-1.8 discussion
>
> According to folks on the Go team, they do not support golang older than
> 1.8 according to an exchange I had about a bug I found and fixed:
>
> https://github.com/golang/mock/issues/119#issuecomment-337968237
>
> Does it make sense to support anything older than golang 1.8 with Thrift
> based on this?  Currently we test against golang 1.4.2 in trusty, 1.6.2 in
> xenial, and 1.8.3 in artful.  We run cross tests in xenial.
>
> If we set the minimum bar at golang 1.7 then we can eliminate all the
> "pre-1.7" go code and x/net/context stuff the project is currently holding
> onto.
>
> Thoughts?
>
> - Jim
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message