thrift-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Woodward (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (THRIFT-4232) ./configure does bad ant version check
Date Mon, 19 Jun 2017 14:29:00 GMT

     [ https://issues.apache.org/jira/browse/THRIFT-4232?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

David Woodward updated THRIFT-4232:
-----------------------------------
    Description: 
On line 18869 of the configure script, it checks that the ant version is >= 1.7. It uses
some kind of string comparison. This breaks for my current ant version (1.10). It seems to
think that 1.10 is not >= 1.7. I think this is because it's comparing strings without taking
into account what the strings actually mean. Something like this might be a possible patch:

https://stackoverflow.com/questions/16989598/bash-comparing-version-numbers

This should be fixed because it means that people with new ant versions can't build the java
thrift library.

Also it should be checked to see if other parts of the configure process are using these kinds
of faulty version checks.

  was:
On line 18869 of the configure script, it checks that the ant version is >= 1.7. It uses
some kind of string comparison. This breaks for my current ant version (1.10). It seems to
think that 1.10 is not >= 1.7. I think this is because it's comparing strings without taking
into account what the strings actually mean. Something like this might be a possible patch:

https://stackoverflow.com/questions/4023830/how-compare-two-strings-in-dot-separated-version-format-in-bash

This should be fixed because it means that people with new ant versions can't build the java
thrift library.

Also it should be checked to see if other parts of the configure process are using these kinds
of faulty version checks.


> ./configure does bad ant version check
> --------------------------------------
>
>                 Key: THRIFT-4232
>                 URL: https://issues.apache.org/jira/browse/THRIFT-4232
>             Project: Thrift
>          Issue Type: Bug
>          Components: Build Process
>    Affects Versions: 0.10.0
>         Environment: OSX 10.12.5, running ant 1.10.1
>            Reporter: David Woodward
>   Original Estimate: 3h
>  Remaining Estimate: 3h
>
> On line 18869 of the configure script, it checks that the ant version is >= 1.7. It
uses some kind of string comparison. This breaks for my current ant version (1.10). It seems
to think that 1.10 is not >= 1.7. I think this is because it's comparing strings without
taking into account what the strings actually mean. Something like this might be a possible
patch:
> https://stackoverflow.com/questions/16989598/bash-comparing-version-numbers
> This should be fixed because it means that people with new ant versions can't build the
java thrift library.
> Also it should be checked to see if other parts of the configure process are using these
kinds of faulty version checks.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message