thrift-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James E. King, III (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (THRIFT-4167) Missing compile flag
Date Wed, 05 Apr 2017 00:33:41 GMT

    [ https://issues.apache.org/jira/browse/THRIFT-4167?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15956116#comment-15956116
] 

James E. King, III commented on THRIFT-4167:
--------------------------------------------

Currently the project requires cmake 2.8.12 or later, which is not sufficient for the cmake
3.1 cxx standard enhancements.
Quite timely, however, I am working on resolving that in THRIFT-4165, which has an open PR
( which failed :( ).
If you don't mind, we can resolve this as a duplicate of THRIFT-4165 as I will be resolving
that shortly.  If you look at the PR you'll see I ended up doing the same thing, but in a
different way.

> Missing compile flag
> --------------------
>
>                 Key: THRIFT-4167
>                 URL: https://issues.apache.org/jira/browse/THRIFT-4167
>             Project: Thrift
>          Issue Type: Bug
>            Reporter: Arnaud Lacombe
>         Attachments: 0001-fix-build.patch
>
>
> While trying to build the following on ubuntu 16.04:
> # cmake -DBUILD_COMPILER=ON -DBUILD_LIBRARIES=ON -DBUILD_TESTING=OFF -DBUILD_EXAMPLES=OFF
-DWITH_CPP=ON -DWITH_BOOST_STATIC=ON -DWITH_STDTHREADS=ON ..
> the build dies on the following:
> In file included from /usr/include/c++/5/thread:35:0,
>                  from /tmp/thrift/lib/cpp/src/thrift/concurrency/Thread.h:32,
>                  from /tmp/thrift/lib/cpp/src/thrift/concurrency/ThreadManager.h:26,
>                  from /build_tmp/thrift/lib/cpp/src/thrift/concurrency/ThreadManager.cpp:22:
> /usr/include/c++/5/bits/c++0x_warning.h:32:2: error: #error This file requires compiler
and library support for the ISO C++ 2011 standard. This support must be enabled with the -std=c++11
or -std=gnu++11 compiler options.
>  #error This file requires compiler and library support
> [...]



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message