thrift-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (THRIFT-4064) Update node library dependencies
Date Wed, 15 Feb 2017 21:18:41 GMT

    [ https://issues.apache.org/jira/browse/THRIFT-4064?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15868579#comment-15868579
] 

ASF GitHub Bot commented on THRIFT-4064:
----------------------------------------

Github user jeking3 commented on a diff in the pull request:

    https://github.com/apache/thrift/pull/1175#discussion_r101385004
  
    --- Diff: build/docker/debian/Dockerfile ---
    @@ -113,8 +113,8 @@ RUN apt-get update && apt-get install -y --no-install-recommends
\
           neko-dev \
           libneko0
     
    -# Node.js dependencies - THRIFT-4064 says it must be >= 4.x
    -RUN curl -sL https://deb.nodesource.com/setup_4.x | bash -
    +# Node.js dependencies - THRIFT-4064 says it must be >= 0.12.0
    --- End diff --
    
    Wasn't the whole pont of this exercise to move up to node 4.x as a minimum supported version?


> Update node library dependencies
> --------------------------------
>
>                 Key: THRIFT-4064
>                 URL: https://issues.apache.org/jira/browse/THRIFT-4064
>             Project: Thrift
>          Issue Type: Improvement
>          Components: Node.js - Library
>    Affects Versions: 0.10.0
>            Reporter: Andres Suarez
>            Assignee: James E. King, III
>
> ws@0.4.32 is really old and presents issues for users using modern versions of Node (see
https://github.com/apache/thrift/pull/672#issuecomment-276678791). Its should be updated.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message