thrift-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James E. King, III (JIRA)" <j...@apache.org>
Subject [jira] [Assigned] (THRIFT-3387) Upgrade from 0.9.2 to 0.9.3 added perl dependencies to my project
Date Mon, 06 Feb 2017 21:56:41 GMT

     [ https://issues.apache.org/jira/browse/THRIFT-3387?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

James E. King, III reassigned THRIFT-3387:
------------------------------------------

    Assignee: James E. King, III

> Upgrade from 0.9.2 to 0.9.3 added perl dependencies to my project
> -----------------------------------------------------------------
>
>                 Key: THRIFT-3387
>                 URL: https://issues.apache.org/jira/browse/THRIFT-3387
>             Project: Thrift
>          Issue Type: Dependency upgrade
>          Components: Perl - Compiler
>    Affects Versions: 0.9.3
>         Environment: Linux CentOS5 and CentOS6 both 32 and 64 bit architectures
>            Reporter: Brian Johnston
>            Assignee: James E. King, III
>
> My project includes the cassandra-client 0.15.2 library, which has a dependency on thrift.
 After the upgrade to thrift 0.9.3, my project, which builds into an rpm, picked up several
perl dependencies.
> My builds prior to 0.9.3 created an rpm with these dependencies:
> Requires: /bin/bash /bin/sh /usr/bin/env config(vex) = 99.0-16903 iinodejs >= 0.10.9
libc.so.6 libc.so.6(GLIBC_2.0) libc.so.6(GLIBC_2.1) libc.so.6(GLIBC_2.1.3) libgcc_s.so.1 libgcc_s.so.1(GLIBC_2.0)
libm.so.6 libpthread.so.0 libpthread.so.0(GLIBC_2.0) libstdc++.so.6 libstdc++.so.6(CXXABI_1.3)
libstdc++.so.6(GLIBCXX_3.4) perl >= 1:5.0 perl(Getopt::Std) perl(IO::File) perl(strict)
rtld(GNU_HASH)
> My builds after 0.9.3 created an rpm with these dependencies:
> Requires: /bin/bash /bin/sh /usr/bin/env /usr/bin/make config(vex) = 99.0-16915 iinodejs
>= 0.10.9 libc.so.6 libc.so.6(GLIBC_2.0) libc.so.6(GLIBC_2.1) libc.so.6(GLIBC_2.1.3) libgcc_s.so.1
libgcc_s.so.1(GLIBC_2.0) libm.so.6 libpthread.so.0 libpthread.so.0(GLIBC_2.0) libstdc++.so.6
libstdc++.so.6(CXXABI_1.3) libstdc++.so.6(GLIBCXX_3.4) perl >= 1:5.6.0 perl(Bit::Vector)
perl(Data::Dumper) perl(Encode) perl(Getopt::Long) perl(HTTP::Request) perl(IO::Select) perl(IO::Socket::INET)
perl(IO::Socket::SSL) perl(IO::String) perl(LWP::UserAgent) perl(POSIX) perl(Thrift) perl(Thrift::BinaryProtocol)
perl(Thrift::BufferedTransport) perl(Thrift::FramedTransport) perl(Thrift::MessageType) perl(Thrift::MultiplexedProtocol)
perl(Thrift::Protocol) perl(Thrift::ProtocolDecorator) perl(Thrift::SSLSocket) perl(Thrift::Socket)
perl(Thrift::Transport) perl(ThriftTest::ThriftTest) perl(ThriftTest::Types) perl(Time::HiRes)
perl(base) perl(constant) perl(lib) perl(strict) perl(utf8) perl(warnings) rtld(GNU_HASH)
> After 0.9.3, I've subsequently forced my project to build with 0.9.2, and now the dependencies
are back to:
> Requires: /bin/bash /bin/sh /usr/bin/env config(vex) = 99.0-16903 iinodejs >= 0.10.9
libc.so.6 libc.so.6(GLIBC_2.0) libc.so.6(GLIBC_2.1) libc.so.6(GLIBC_2.1.3) libgcc_s.so.1 libgcc_s.so.1(GLIBC_2.0)
libm.so.6 libpthread.so.0 libpthread.so.0(GLIBC_2.0) libstdc++.so.6 libstdc++.so.6(CXXABI_1.3)
libstdc++.so.6(GLIBCXX_3.4) perl >= 1:5.0 perl(Getopt::Std) perl(IO::File) perl(strict)
rtld(GNU_HASH)



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message