thrift-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Roger Meier" <ro...@bufferoverflow.ch>
Subject AW: Exception in SSL_read: Wrong Version Number
Date Mon, 05 Nov 2012 21:17:06 GMT
I've no idea for the moment...

Do you have a test case to reproduce it?
e.g. within cross language test suite started via test/test.sh

-roger

> -----Urspr√ľngliche Nachricht-----
> Von: Isuru Haththotuwa [mailto:isurulucky@gmail.com]
> Gesendet: Sonntag, 4. November 2012 13:06
> An: dev@thrift.apache.org
> Betreff: Exception in SSL_read: Wrong Version Number
> 
> Hi all,
> 
> I'm in the process of learning thrift. I wrote a secure client in C++ to connect
> to a thrift server, authenticated via SSL. First I wrote a single threaded
> application, which ran without any issues. But, when I try to send requests to
> the server concurrently with multiple threads, the program fails with the
> following exception:
> 
> *
> terminate called after throwing an instance of
> 'apache::thrift::transport::TSSLException'
>   what():  SSL_read: wrong version number terminate called recursively*
> 
> 
> Kindly let me know what is the issue here, and how should I avoid it.
> 
> --
> Thanks and Regards,
> Isuru


Mime
View raw message