tez-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ss...@apache.org
Subject tez git commit: TEZ-2468. Change the minimum Java version to Java 7. (sseth)
Date Thu, 21 May 2015 00:20:44 GMT
Repository: tez
Updated Branches:
  refs/heads/master 70a465dfb -> 7c16b10e2


TEZ-2468. Change the minimum Java version to Java 7. (sseth)


Project: http://git-wip-us.apache.org/repos/asf/tez/repo
Commit: http://git-wip-us.apache.org/repos/asf/tez/commit/7c16b10e
Tree: http://git-wip-us.apache.org/repos/asf/tez/tree/7c16b10e
Diff: http://git-wip-us.apache.org/repos/asf/tez/diff/7c16b10e

Branch: refs/heads/master
Commit: 7c16b10e2a251628c0fba3e61327fe5d464ba231
Parents: 70a465d
Author: Siddharth Seth <sseth@apache.org>
Authored: Wed May 20 17:20:30 2015 -0700
Committer: Siddharth Seth <sseth@apache.org>
Committed: Wed May 20 17:20:30 2015 -0700

----------------------------------------------------------------------
 BUILDING.txt |  2 +-
 CHANGES.txt  |  1 +
 pom.xml      | 39 +++++++++++++++++++++++++++++++++++----
 3 files changed, 37 insertions(+), 5 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/tez/blob/7c16b10e/BUILDING.txt
----------------------------------------------------------------------
diff --git a/BUILDING.txt b/BUILDING.txt
index 5247b9d..17500d5 100644
--- a/BUILDING.txt
+++ b/BUILDING.txt
@@ -6,7 +6,7 @@ https://cwiki.apache.org/confluence/display/TEZ
 ----------------------------------------------------------------------------------
 Requirements:
 
-* JDK 1.6+
+* JDK 1.7+
 * Maven 3.0 or later
 * Findbugs 2.0.2 or later (if running findbugs)
 * ProtocolBuffer 2.5.0

http://git-wip-us.apache.org/repos/asf/tez/blob/7c16b10e/CHANGES.txt
----------------------------------------------------------------------
diff --git a/CHANGES.txt b/CHANGES.txt
index 32118e7..d1070f8 100644
--- a/CHANGES.txt
+++ b/CHANGES.txt
@@ -5,6 +5,7 @@ Apache Tez Change Log
 Release 0.8.0: Unreleased
 
 INCOMPATIBLE CHANGES
+  TEZ-2468. Change the minimum Java version to Java 7.
 
 ALL CHANGES:
   TEZ-2454. Change FetcherOrderedGroup to work as Callables instead of blocking threads.

http://git-wip-us.apache.org/repos/asf/tez/blob/7c16b10e/pom.xml
----------------------------------------------------------------------
diff --git a/pom.xml b/pom.xml
index c48515b..44592fa 100644
--- a/pom.xml
+++ b/pom.xml
@@ -40,6 +40,8 @@
     <hadoop.version>2.6.0</hadoop.version>
     <jetty.version>6.1.26</jetty.version>
     <pig.version>0.13.0</pig.version>
+    <javac.version>1.7</javac.version>
+    <enforced.java.version>[${javac.version},)</enforced.java.version>
     <distMgmtSnapshotsId>apache.snapshots.https</distMgmtSnapshotsId>
     <distMgmtSnapshotsName>Apache Development Snapshot Repository</distMgmtSnapshotsName>
     <distMgmtSnapshotsUrl>https://repository.apache.org/content/repositories/snapshots</distMgmtSnapshotsUrl>
@@ -667,12 +669,17 @@
           <artifactId>maven-compiler-plugin</artifactId>
           <version>3.1</version>
           <configuration>
-            <source>1.6</source>
-            <target>1.6</target>
+            <source>${javac.version}</source>
+            <target>${javac.version}</target>
           </configuration>
         </plugin>
         <plugin>
           <groupId>org.apache.maven.plugins</groupId>
+          <artifactId>maven-enforce-plugin</artifactId>
+          <version>1.4</version>
+        </plugin>
+        <plugin>
+          <groupId>org.apache.maven.plugins</groupId>
           <artifactId>maven-jar-plugin</artifactId>
           <version>2.4</version>
           <executions>
@@ -854,6 +861,30 @@
 
     <plugins>
       <plugin>
+        <groupId>org.apache.maven.plugins</groupId>
+        <artifactId>maven-enforcer-plugin</artifactId>
+        <version>1.4</version>
+        <inherited>false</inherited>
+        <executions>
+          <execution>
+            <id>clean</id>
+            <goals>
+              <goal>enforce</goal>
+            </goals>
+            <configuration>
+              <rules>
+                <requireMavenVersion>
+                  <version>[3.0.2,)</version>
+                </requireMavenVersion>
+                <requireJavaVersion>
+                  <version>${enforced.java.version}</version>
+                </requireJavaVersion>
+              </rules>
+            </configuration>
+          </execution>
+        </executions>
+      </plugin>
+      <plugin>
         <groupId>org.apache.rat</groupId>
         <artifactId>apache-rat-plugin</artifactId>
       </plugin>
@@ -1061,8 +1092,8 @@
             <artifactId>maven-compiler-plugin</artifactId>
             <configuration>
               <fork>true</fork>
-              <source>1.6</source>
-              <target>1.6</target>
+              <source>${javac.version}</source>
+              <target>${javac.version}</target>
               <compilerArguments>
                 <Xlint/>
                 <Xmaxwarns>9999</Xmaxwarns>


Mime
View raw message