teaclave-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Blaine Malone <notificati...@github.com.INVALID>
Subject [apache/incubator-teaclave-sgx-sdk] Use simulation mode on MacOS (#318)
Date Tue, 23 Feb 2021 22:10:59 GMT
**Specs: MacBook Pro (16-inch, 2019), 2.3 GHz 8-Core Intel Core i9**

When following the instructions outlined [here](https://github.com/apache/incubator-teaclave-sgx-sdk#use-simulation-mode-for-non-sgx-enabled-machine-includes-macos).

I get the following error:

```
./lib/libenclave.a(sgx_trts-e1de7fe3db2688ea.sgx_trts.c1x8g4sc-cgu.2.rcgu.o): In function
`sgx_trts::enclave::SgxGlobalData::new::hd171d7330c2c7ee0':
sgx_trts.c1x8g4sc-cgu.2:(.text._ZN8sgx_trts7enclave13SgxGlobalData3new17hd171d7330c2c7ee0E+0xa5):
undefined reference to `get_rsrv_base'
sgx_trts.c1x8g4sc-cgu.2:(.text._ZN8sgx_trts7enclave13SgxGlobalData3new17hd171d7330c2c7ee0E+0xb2):
undefined reference to `get_rsrv_size'
collect2: error: ld returned 1 exit status
Makefile:155: recipe for target 'enclave/enclave.so' failed
make: *** [enclave/enclave.so] Error 1
```

Steps to reproduce: 
```
1. docker pull baiduxlab/sgx-rust-stable
2. docker run -v /Users/<user.name>/code/incubator-teaclave-sgx-sdk:/root/sgx -ti baiduxlab/sgx-rust-stable
3. cd sgx/samplecode/helloworld/
4. Edited the Makefile to run in SW mode 
5. make && cd bin
6. ./app
```

I've seen some closed issues on this repo that report _similar_ errors, but none of those
fixes work in this case.

**Side Notes:**
- Do I need to have the [linux-sgx](https://github.com/intel/linux-sgx) sdk installed on my
Macbook? (The docker container includes all necessary libraries right?)
- I have tried the latest build too and that's gave the same error, `baiduxlab/sgx-rust`.


-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/apache/incubator-teaclave-sgx-sdk/issues/318
Mime
  • Unnamed multipart/alternative (inline, 7-Bit, 0 bytes)
View raw message