tcl-websh-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lost One <the.lost...@yahoo.com>
Subject Compile problems
Date Fri, 23 Oct 2009 09:34:09 GMT
Hello
I have (successfully) compiled Websh before (with a lot of searching and work..) but now it
seems that i just can't compile the newer version. I'm using Tcl 8.6b1 and apache 2.2.14.
I tried using the compiled apache and also the uncompiled one but it just won't work.I always
get errors, sometimes the arp.h is missing, other times the libhttpd.lib is missing although
the libhttpd.dll exists.
Last time I tried to do everything i got this error:Microsoft (R) Program Maintenance Utility
Version 9.00.21022.08
Copyright (C) Microsoft Corporation.  All rights reserved.

        cl /D"WIN32" /D"VERSION=\"3.6.0b5\"" /D"_MBCS" /W3 /EHsc /O2 /Ob1 /DTHRE
AD_SAFE=1 -I"D:/Tcl/include" -I"D:/Tcl/Apache/include" -UUSE_TCL_STUBS -c ../gen
eric/interpool.c /Fointerpool.obj
Microsoft (R) 32-bit C/C++ Optimizing Compiler Version 15.00.21022.08 for 80x86
Copyright (C) Microsoft Corporation.  All rights reserved.

interpool.c
d:\tcl\websh-3.6.0b5\src\generic\mod_websh.h(23) : fatal error C1083: Cannot ope
n include file: 'httpd.h': No such file or directory
NMAKE : fatal error U1077: '"C:\Program Files (x86)\Microsoft Visual Studio 9.0\
VC\BIN\cl.EXE"' : return code '0x2'
Stop.

Could you please be able to tell me how you did it precisely, cause i can't quite remember
how i made it work the last time. Do I have to compile Apache separated or do I need the TCL
source?
Thanks in advance.




      
Mime
View raw message