tcl-rivet-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Matthias Luettgert <matthias.luettg...@risa.de>
Subject Strange starting message when loading mod_rivet.so
Date Wed, 08 Oct 2003 22:17:12 GMT
Hello,

I just tried to set up rivet under SuSE Linux 8.2
with tcl 8.4 (info patchlevel: 8.4.2)
After installing Apache Headers, rivet simply compiled.
(./make.tcl shared) .
When starting Apache, I receive the following message:
Starting httpd [ ][Thu Oct  9 02:06:37 2003] [warn] Loaded DSO
/usr/lib/apache/mod_rivet.so uses plain Apache 1.3 API,
 this module might crash under EAPI!
(please recompile it with -DEAPI)

How do I do that?
My attempts on configure.in.tcl have been all useless. My -DEAPI
was thrown out everytime.

The Apache is
Server version: Apache/1.3.27 (Linux/SuSE)
Server built:   Mar 14 2003 02:26:04

Anyway, my first attempt with hello.rvt (in htdocs directory) lead
to the poor result:
The file "hello.rvt" is of type application/x-httpd-rivet, and
Netscape does not know how to handle this file type...

Do I need a plugin?

How do I use Tcl on the server side? My <? puts "any tcl" ?>
fragments seem to be simply ignored.

Is this all a result of omitting -DEAPI on compiling rivet?

Help apreciated.


Matthias Lüttgert


---------------------------------------------------------------------
To unsubscribe, e-mail: rivet-user-unsubscribe@tcl.apache.org
For additional commands, e-mail: rivet-user-help@tcl.apache.org


Mime
View raw message