tcl-rivet-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Massimo Manghi <man...@biol.unipr.it>
Subject Re: manipulating http headers with rivet
Date Mon, 19 Feb 2007 22:21:00 GMT
Quoting David Welton <davidnwelton@gmail.com>:

> This works for me with a relatively up to date Rivet:
>
> <?
> headers type "text/plain"
> puts "hello world"
> ?>

Nope, headers are immutable.

>
> I'm not sure what problems it might have... you have to make sure the
> headers haven't already been sent over the wire when you do 'headers
> type', but I can't think of much else...
>

setting the headers after they have been sent over causes an error
(it happened to me in the very early experiments i made with Rivet )
I confess that my set up is not absolutely clean: i compiled the module
on my own in order to have the whole set of rivet commands (never
got around the problem that keeps out of the linking process a whole
library) but i kept the tcl library that comes with the Debian package
for 'unstable'. Never had problems except for the cases when I was
unable to let things work the way they're supposed to work.


-- Massimo Manghi



----------------------------------------------------------------
This message was sent using IMP, the Internet Messaging Program.
----------------------------------------------------------------
Imp3 - Webmail del Dipartimento di Biologia Evolutiva e Funzionale

---------------------------------------------------------------------
To unsubscribe, e-mail: rivet-dev-unsubscribe@tcl.apache.org
For additional commands, e-mail: rivet-dev-help@tcl.apache.org


Mime
View raw message