tcl-rivet-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From dav...@dedasys.com (David N. Welton)
Subject Re: mod_rivet.so unable to find libtcl8.4.so
Date Thu, 24 Jul 2003 19:23:55 GMT
fxper <fxper@yahoo.com> writes:

> [root@californiaclassics root]# ldd
> /usr/local/apache/libexec/mod_rivet.so
>         libtcl8.4.so => not found
>         libdl.so.2 => /lib/libdl.so.2 (0x4001a000)
>         libm.so.6 => /lib/tls/libm.so.6 (0x4001e000)
>         libcrypt.so.1 => /lib/libcrypt.so.1
> (0x40041000)
>         libc.so.6 => /lib/tls/libc.so.6 (0x42000000)
>         /lib/ld-linux.so.2 => /lib/ld-linux.so.2
> (0x80000000)
> 
> My install didn't have TCL, so yes I installed it myself.

Well, it looks like /usr/local/lib isn't in your /etc/ld.so.conf file.

So, you have a couple of options.  As Holger rightly says, you can use
LD_LIBRARY_PATH=/usr/local/lib/ and that should make things work ok,
but you have to remember to always do it.

Another more permanent way of fixing things up would be to add
/usr/local/lib/ to ld.so.conf and then run ldconfig.  More information
in man ldconfig.

Try one of those and see if it fixes things...

-- 
David N. Welton
   Consulting: http://www.dedasys.com/
     Personal: http://www.dedasys.com/davidw/
Free Software: http://www.dedasys.com/freesoftware/
   Apache Tcl: http://tcl.apache.org/

---------------------------------------------------------------------
To unsubscribe, e-mail: rivet-dev-unsubscribe@tcl.apache.org
For additional commands, e-mail: rivet-dev-help@tcl.apache.org


Mime
View raw message