tcl-rivet-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dmitry the Zuryanovich <...@xepb.ru>
Subject What does it want?
Date Tue, 29 Jul 2003 18:49:48 GMT
Hi there,

 during today I've been upgrading apache+php and all the related 
stuff.

 Currently it says :

bash-2.05a# /usr/local/apache/bin/apachectl start
[Tue Jul 29 22:27:04 2003] [warn] Loaded DSO libexec/mod_rivet.so uses plain \
  Apache 1.3 API, this module might crash under EAPI! (please recompile it \
 with -DEAPI)
[Tue Jul 29 22:27:05 2003] [error] <other warnings>>

 Before I've recompiled PHP, it said the same thing about PHP. (I had not
add any -DEAPI, just told where the updated apache apxs lives)

 I've recompiled Rivet (via make.tcl clean; make.tcl dynamic or like that), 
I'm sure it has the "set APXS blah" pointing to the current upgraded apache 
apxs binary. 

 The changes vs prev configuration are: (the system is OpenBSD 3.1 with
myself-compiled apache, not from ports/packages, i386)
 - apache - 1.3.27 => 1.3.28
 + mod_ssl
 (some changes in PHP configuration, but I think they are not significant)

 mod_rivet still works. Should I ignore the warning? (or just get the newer
version from cvs? ;-))

 What's the EAPI anyway? Is it new interface of apache .28 vs .27?

 By the way, I'm still happy with apache 1.3.x, but I suppose one day
we all have to migrate to 2.x branch. Will I have problems with rivet?

Thanks.
-- 
 DtZ (homepage:http://xepb.ru/dtz ,ICQ UIN:5132840,Fido: 2:5020/730)
jabber://dtz@theoretic.com //HPG
 

---------------------------------------------------------------------
To unsubscribe, e-mail: rivet-dev-unsubscribe@tcl.apache.org
For additional commands, e-mail: rivet-dev-help@tcl.apache.org


Mime
View raw message